Skip to content

Parse error

Discussion about Free Wallpaper Script. Installation, bugs, feature requests, modification and other questions.
Questions about installation of wallpaper script
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #369


    when I try to install the script, this error appears:

    Parse error: syntax error, unexpected ‘=’, expecting ‘(‘ in /homepages/XX/XXXXXX/VEPPA/index.php on line 67

    How can I fix this, please help


    Can you check if index.php file uploaded correctly without interruptions? it may be that file not uploaded completely.

    Did you run through setup process? or is this error comes on your first visit to your site? Also what is your php version?



    you were right, my php version was 4.2.6 and I added this to htaccess AddType x-mapp-php5 .php and AddHandler x-mapp-php5 .php

    Then it worked great. But now theres one problem. I can’t vote. When I press the thumb up or down, there comes that loading bar, and thats it. The script does not vote. nor up nor down.

    Do you know why?


    Can you give url for your site to see what is the problem? or check if BASE_URL (javascript definition in template used in all pages) is defined correctly in html source. If loading bar shows then jquery is working but BASE_URL may be not defined. You can use firebug extension for firefox to see where javascript breaks.



    the scripts running on .

    I hope you can find the problem. And hey, your script is awesome!!


    It might be some problem in .htaccess file. because /index/rate/ is not loading but /tag/tree/ or other links without /index/ works. So your .htaccess file is not passing that request to index.php.


    Okay, nice to hear… but how could the htaccess file look like, so it might work? could you post an example, please?

    Mine looks like this right now

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    #Options +FollowSymLinks
    AddDefaultCharset UTF-8

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    # Main URL rewriting.
    RewriteRule ^(.*)$ index.php?$1 [L,QSA]


    Thank for your help


    Can you try several variations?

    1- put .htaccess file to /VEPPA/ folder if it is not there already
    then change RewriteBase / to RewriteBase /VEPPA/
    2.a- if this .htaccess file located in /VEPPA/ then check / folder for .htaccess file and try renaming it to see if that was problem.
    2.b- if this .htaccess in / then check /VEPPA/ for .htaccess and try renaming it to find if that is problem.

    I think trying opption 1 will fix your problem.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.